
User Guide 

Order Entry 

for the PSION SERIES 3 

The Order program lets you: 

• Enter, review and amend orders to your wholesaler, using 
item codes. 

• Transmit the orders by telephone directly to (or when 
called by) your wholesaler. 

• Review on screen the outcome report from the wholesaler. 

Connection to the public telephone system is through the Psion 
3-Link accessory and a Hayes compatible or manual modem. 
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Starting the Order program 
Users unfamiliar with the Psion Series 3 may find it helpful to read Psion's 
User Guide Chapter 1 Getting Started and to refer to its index for 
information on some of the terms used below. 

With the Series 3 turned ON, press (firmly) the leftmost button, labelled 
System, in the row of eight between screen and keyboard1. A row of icons 
(symbols similar to those on the buttons) appears on the screen: use the 
arrow keys to move the highlight onto a word under the icon 
symbolising an order form: 

 

Now press the Enter key to start the program. You should see a screen like 
this: 

 

The status window on the right contains the Order icon (symbolising 
the program currently on-screen). The word Order between icon and clock 
is the name of the file holding this particular order. As explained on page 
22, if you wish you can have several separate order files; on this occasion 
Order was selected because its name was highlighted when starting the 
program. 

                                                           

1 Each button top is marked with an icon: a small symbol depicting the application 
it calls. Your installer may have assigned one of the other buttons to the Order 
program; if so it is quicker to press this instead. 
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The main window on the left is a representation of an order form, which 
may be thought of as split into two panes by the lower horizontal line: the 
upper editing pane (empty in the figure) is used for editing and for 
viewing up to six lines whilst the lower loading pane is used to add 
new lines. The flashing blob in the loading pane under Item Code is 
called the cursor. 

Your tool kit 
The presence of the cursor indicates that the program is waiting for you to 
enter something at the keyboard; its position attempts to suggest what this 
might be as it shows where valid input will be placed on the screen. 
However, wherever possible the program will also respond to the keys listed 
below. Please note that in order to obtain a key action inscribed on the 
Series 3 in yellow you must press that key whilst holding down the PSION 
key (the key in the bottom left hand corner with the yellow bar above it). 

• The Help key pops-up windows containing condensed information 
about the basic operation of the Order program. 

• The menu cards which appear on successive presses of the Menu key 
list tools the program provides: 

 

To pick a tool, move the highlight to it using the four keys marked with 
arrows and then press Enter. Three dots after the tool name indicate that a 
dialog box will pop-up before the tool is run, allowing you to specify 
precisely how the tool is to be used on this occasion. The letter alongside 
the PSION symbol in the right hand column of each menu card gives the 
tool's hotkey: once you are familiar with the hotkey you may by-pass the 
menu by pressing the hotkey letter whilst holding down the PSION key. 

• The four keys marked with arrows let you navigate around the 
current dialog box or as described elsewhere in this guide. PgUp, Home, 
PgDn, End may increase movement. Within a dialog box text field, 
Shift+arrow extends the selected (highlighted) text. 
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• The Delete key removes any keystroke to the left of the cursor. 
Within a dialog box text field, Delete first removes any selected text. 

• The Esc key lets you cancel the current field, help window, menu, 
dialog box or tool, restoring the previous state. 

• The Shift and Caps Lock keys may be used as you wish. Case is not 
significant when entering hotkeys, item codes or passwords. 

• As the Series 3 is a multi-tasking computer you may also switch 
between tasks with the row of eight buttons, subject to there being 
enough system memory available for all activities. 

• The Off key switches the Series 3 off immediately. If the Order 
program was running, it resumes at the same point when you switch on 
again. By default, the Series 3 switches off automatically if it has not 
been used for five minutes. Of course, this is important when running 
off batteries, but you may change the time interval through the 
System button's Special menu Options dialog. 

Within a dialog box, Esc cancels the entire box not just the current field 
and Enter completes the entire box. 

Your memory resource 
Your Series 3's Random Access Memory (RAM) supplies the System 
Memory  needed by the operating system to support active tasks and the 
memory needed by the Internal Disk Drive to keep your files. 
RAM can run out if too many Series 3 features are active at the same time, 
especially with the 128K RAM model (a minor irritation when set against 
the advantages of multi-tasking). The Free space tool under the File 
menu will tell you how many bytes are available on the disk holding the 
current order file. In practice, provided this disk is the Internal Disk, it is 
actually indicating the available RAM. 

If you are inconvenienced by shortage of available RAM, you must release 
some: 

• By shutting down other tasks for the time being. Press the System 
button and move the highlight onto bold file names. Press Delete and 
follow the instructions on the screen. 
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• By deleting obsolete files from the Internal Disk. 

• By moving large active files onto a SSD (Solid State Disk). 

Entering Items in the order 
You need to know, for each item you wish to order, either the seven 
digits “Pharmaceutical Interface Products Code” (PIP-Code, e.g. 001-1866) 
as issued by the National Pharmaceutical Association Ltd. or your 
wholesaler's own Product Code2 (e.g. 423J). 

Whenever you start the Order program, or switch order files, the cursor will 
be in the loading pane under Item Code, as in the figure on page 3. 
In this figure the order is empty, so the number in the loading pane's Line 
column indicates that the next item entered will be placed in line 1 of the 
order. In fact, the program always adds new lines at the end of the order so 
this number is always one greater than the number of lines. 

Key in the first Item Code, using Delete or Esc to correct any mistake. 
When entering a PIP Code all seven digits are required; however, the 
distinguishing dash after the third digit is inserted automatically. The 
program tries to catch incorrect item codes by verifying the check 
digit designed into the PIP Code or the check letter at the end of 
the Wholesaler Code. A beep sound indicates this verification failed and 
you must correct or cancel the Item Code. If the Item Code appears valid 
the cursor jumps automatically into the Qty column. 

                                                           

2 But only if your wholesaler uses codes in the form of up to five digits followed by 
a single letter. 
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PIP Codes beginning with 0 
At the time of writing almost all PIP Codes begin with the digit 0. To avoid 
having to key this digit every time, you may find the Zero lead-in tool 
(available under the Format menu) helpful: 

 

Changing the number of 0's pre-set from 0 to 1 instructs the program to feed 
one 0 digit into the Item Code field automatically (to remove it for large PIP 
Codes press Delete)3. If you wish, you may pre-set up to four 0 digits. 

Specifying the Quantity 
When the cursor jumps to the Qty field within the loading pane, the 
quantity is pre-set to one as indicated by the digit 1 under the cursor. If a 
single unit is required just press Enter otherwise overtype the 1 with the 
number of units required then press Enter. In either case a pip sound 
signals that entry of this line is completed and it is scrolled up into the 
editing pane. This clears the loading pane which is immediately 
ready for the next Item Code to be entered. 

Ordering by the Case 
Instead of pressing Enter at the end of the line, press the letter C. A pip 
sound signals that entry of the line is completed and it is scrolled up into the 
editing pane. The word Cases alongside the quantity entered 
confirms the measure. 

                                                           

3 The preference you set here, as with dialog settings for most other tools, is 
recorded within the current order file and will therefore be applied automatically 
each time you work with this file. 
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Please note that if your wholesaler does not take orders quoting cases then 
their computer will ignore the measure (i.e. treat all cases as containing one 
unit). 

If your wholesaler will only supply this order in cases, the word Cases will 
appear alongside the quantity as a reminder even if you pressed Enter at 
the end of the line. 

Asking for an item “To Follow” 
When your wholesaler is temporarily out of stock of an item, you may find 
yourself re-entering the line on many successive orders until it becomes 
available. If your wholesaler operates a Back Order service you can 
avoid this by asking for any shortage to follow automatically when it 
becomes available: just press the * key once at any point before completing 
entry of the relevant line. A * appears in the loading pane as confirmation 
(if you hear a beep sound instead then your wholesaler does not operate 
this service). 

Please note that the wholesaler's outcome report (and invoice) will indicate 
whether or not any shortage has actually been placed onto back order for 
you. 

Requesting “To Follow” automatically 
If you usually want shortages to follow automatically, the auto To 
follow tool under the Format menu lets you instruct the program to pre-
set the To Follow marker automatically for all new lines. If you do this, 
pressing the * key once during entry of a line will remove the request on 
that line (the * is removed from the loading pane as confirmation). 
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Adding an Order Reference 
The order Ref tool under the Edit menu lets you add or change your 
own reference for this order at any time: 

 

The reference is a maximum of eight characters. When you complete the 
dialog by pressing Enter, your reference will be displayed above the main 
window. It will also be transmitted with your order and your wholesaler will 
probably print it on any ensuing invoices. Note: the program converts lower 
case letters to upper case to avoid any problems lower case might possibly 
cause on your wholesaler's computer system. 

Reviewing the Order 
After a number of lines have been added to the order, the screen will look 
something like this: 

 

Only six of the lines can be shown in the editing pane at one time, however 
once the order has grown sufficiently large the pane may be scrolled up or 
down the order: 
 by one line with each press of Up Arrow or Down Arrow, 
 by six lines with each press of PgUp or PgDn, 
 to the first six lines by pressing Home, 
 to the last six lines by pressing End. 
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Editing the Order 

Changing or erasing a line 
To alter or remove a line already entered in your order, you need to move 
the cursor into the editing pane alongside the relevant quantity: 

 

There are two ways to get the cursor into the editing pane: 

• Type the relevant Item Code into the loading pane as if it were not 
yet ordered. Because it is ordered, the line will be displayed in the 
editing pane with the cursor alongside the quantity. 

• Press Tab. This moves the cursor alongside the quantity on one of the 
lines already visible in the editing pane. Then use arrow keys to 
reach the relevant line: 

move by one line with each press of Up Arrow or Down Arrow 
or (locking the cursor) Shift+Up Arrow or Shift+Down Arrow, 
move by six lines with each press of PgUp or PgDn, 
move to the first line by pressing Home, 
move to the last line by pressing End. 

To return to the loading pane: press Esc, Tab or Enter. Esc will cancel 
any change you were making to the quantity whilst Tab or Enter will 
complete it. 

If you use any arrow key to move to another line, this will complete any 
change you were making on the current line. This feature allows you to 
make changes quickly to several lines. 

For clarification, a pip sound is made whenever any change becomes 
effective (i.e. is completed). 
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• To set the quantity to any new value: first press Delete to remove at 
least one digit, then type in the new value, then move the cursor out of 
the line (e.g. by pressing Enter). This scheme is intended to reduce the 
possibility of accidental changes to the quantity. Setting the quantity to 
0 will remove this line from the order. 

• To increase the quantity by one: press +. 

• To decrease the quantity by one: press -. However, you cannot set the 
quantity to zero by this method. 

• To switch the measure from units to cases or vice versa: press the letter 
C. 

• To switch the To Follow marker: press *. 

• To remove the line: set the quantity to 0 and move the cursor out of the 
line (e.g. by pressing Enter). 

To erase all lines 
Use the Delete all items tool under the Edit menu: 

 

Press Delete to confirm the operation. In case you ever do this 
inadvertently please remember that you may restore the order with the 
Undo delete tool under the Edit menu. However, this tool cannot help 
after you have loaded a new line into the empty order, i.e. if the Edit menu 
shows (can't Undo). 
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Transmitting your orders 

Setting Up 
• Ensure that the Series 3 is securely connected to the public telephone 

system through the Psion 3-Link accessory and modem, on a 
telephone line that won't be used by anyone else. The 3-Link plugs into 
the side of the Series 3, just above the Esc key. 

• Ensure that the Series 3's Disk Drive doors, marked A and B on the 
underside of the Series 3, are both closed. 

• It is a good idea to use the mains adapter. Battery consumption 
increases during communication. 

• Pick the Send tool from the File menu. You will see a dialog box 
similar to this4: 

 

The dialog box has four fields, described following, any of which you may 
alter after moving the highlight to the field with Up Arrow or 
Down Arrow. When ready, press Enter to start the Send tool, or press Esc 
to cancel. 

In the Dial field the cursor has been replaced by a spin box: the two 
thick arrows indicate you are being asked to choose one from a limited 
number of choices. Each press of left arrow or right arrow rotates 

                                                           

4 The Send tool needs additional memory to run and to record your wholesaler’s 
outcome report. If less than 6,000 bytes are available, you will first be asked to 
confirm you wish the program to close all other applications automatically. If this 
releases enough memory, the above dialog box appears. Alternatively, press the 
System button and resolve the problem by hand. 
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the selection to the next choice. Alternatively, press Tab to reveal all 
choices: 

 

Use up arrow or down arrow to move the highlight to your choice, 
then press Enter to return to the main dialog box. 

• If you are going to dial by hand, or have been called by your 
wholesaler, choose no autodial. 

• If you have a Manual modem (one which cannot dial) you can ask the 
Series 3 to dial by choosing one of the three phone lines. Check you 
have dial tone and put the Series 3's speaker right up to the telephone 
mouthpiece. (This only works if your telephone system understands 
modern DTMF signals.) 

• If you want your Hayes compatible modem to dial, choose one of 
the three phone lines. With most of these modems, it is important to 
keep your handset on the hook whilst the modem is active; some 
provide a loudspeaker so you can hear what's happening. 

The File(s) fields, Name and Disk, are always pre-set to the current 
order file. See page 18 if you wish to send a group of separate order files to 
your wholesaler in a single telephone call, or to send an order file for 
another wholesaler to this wholesaler instead. 

The Signal at end spin box has no effect other than to set your 
preference for how the Series 3 lets you know it has finished using your 
telephone: choose chimes, rings or mute (silence). 
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On the wire 
After you close the Send dialog by pressing Enter, when all goes well 
there is nothing for you to do until the screen shows Done with phone 
(optionally accompanied by an audible signal at end), as seen here: 

 

Troubleshooting 
Before you reach the above state, the program gives various indications 
which may help you determine whether you need to intervene: 

• on the line below the wholesaler's name, information about the current 
state (see page 16). 

• within the framed window, lines showing significant data received from 
the modem. The above figure shows three lines, viz. (1) the echo of the 
command instructing the Hayes compatible modem to go on line 
without dialling, (2) the modem's “result code” advising it has 
connected with a remote modem and (3) the outcome message from the 
remote computer system. Only the five lines most recently presented 
remain visible (you cannot scroll this window). 

• a short low “rasp” sound from the Series 3, should the software at one 
end not hear the other correctly. This indicates a delay whilst some data 
is repeated. If this sound is persistent you have a weak connection; 
check that your own handset is not interfering and that no one is trying 
to use the telephone line via another extension. 

• a message such as “Serial overrun” in the bottom right hand corner, 
indicating mismatched communication between Series 3 and local 
modem. 

• on the line under the framed window, one of the messages explained in 
the following table: 
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Press [Esc] Nothing to send 
The file(s) you specified in the Send dialog either do not exist or are all 
empty. The program only attempts to connect to your wholesaler when 
there is something to send. 

Press [Esc] Device does not exist 
The Psion 3-Link accessory is not plugged in to the Series 3. 

Press [Esc] File or device in use 
Another task on the Series 3 has reserved the 3-Link accessory. Shut down 
that task; if you don't know which it is check that the System button's 
Special menu remote Link is OFF. 

Press [Esc] to cancel order 
Shown while disconnection will result in your wholesaler's software 
discarding the entire order currently on the wire. 

Press [Esc] to cancel reply 
Shown while disconnection will result in an incomplete outcome report 
from your wholesaler for the order currently on the wire. The wholesaler's 
software will continue processing the entire order after any such 
disconnection. 

Press [Esc] Line failure 
Disconnection occurred due to some cause external to the Series 3. 

Press [Esc] Too many retries 
The Series 3 disconnected because eight consecutive attempts to send or 
receive data failed. 

Press [Esc] Inactivity timeout 
The Series 3 disconnected because expected data was not received for 16 
seconds. 

Press [Esc] Done with phone 
The Series 3 disconnected because the Send tool has finished. 

Disconnection 
In the preceding table, disconnection refers to the breaking of contact 
between the Series 3 program and your wholesaler's software; pressing the 
Esc key will always force immediate disconnection. The telephone call 
normally remains engaged until the end that's paying “hangs-up” all its 
equipment (in this case modem and handset). Many auto-dial modems hang-
up automatically when the software disconnects but it's wise to confirm this 
yourself (pick up your handset and listen). Of course, a manual modem will 
need switching from Data. The telephone line reverts to speech after your 
modem hangs-up.  
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The program's primary objective, in co-operation with your wholesaler's 
software, is to send every order accurately without loss or duplication. 
Waiting for the wholesaler's outcome report is a secondary objective which 
you may cancel if you wish5. For clarification, the Series 3 gives a pip 
sound to mark the point beyond which you may disconnect confident that 
the wholesaler has your order. 

The status line 
Any communication attempt proceeds through a definable sequence of 
states, reported by the status line as described in the following table. The 
final state remains on screen until you escape from the Send tool. 

Press modem DATA on hearing far tone  or  Waiting for local modem 
This state exists until the Series 3 detects the “Data Set Ready” (DSR) and 
“Clear to Send” (CTS) signals from the modem. 
The first form appears when the Order program is set up for use with a 
manual modem. This modem has a switch or button to set it on/off line 
(usually marked DATA/TALK). If there is also a setting for 
Originate/Answer you must select Originate (even when your 
wholesaler has called you). Please select DATA promptly on hearing the 
steady tone of your wholesaler's modem in your handset. 
The second form appears when the Order program is set up for use with 
an automatic modem. You may not notice it because the modem should be 
ready almost straight away. 

                                                           

5 and so may your wholesaler, for example if the master data base temporarily 
cannot be interrogated for stock availability. 
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Trying to connect to wholesaler 
If this state is not reached, first check your modem has power then pull 
apart and refit all cabling (including power). The state exists until data is 
received from your wholesaler's software. 
Any command issued to an automatic modem should appear in the framed 
window, and dialling should be taking place if this was requested. Hang 
up your handset now (unless your modem has cut it off and you intend to 
speak to your wholesaler afterwards). 

File x.EOE (n lines): Trying to log on 
This state confirms you are connected to your wholesaler's software6. It 
exists whilst the wholesaler's software is interpreting the “header” data 
contained in your Series 3 file named x.EOE. If the log on fails you may 
see in the framed window a brief explanation from the wholesaler (such as 
“wrong password”). 

File x.EOE (n lines): Sending line i 
This state confirms that your order x.EOE is now being sent. i should 
increment by 10 (the blocking factor) until it reaches n. 

File x.EOE (n lines): Awaiting reply 
This state confirms that all n lines of your order x.EOE have now been 
sent. 
To prevent you inadvertently duplicating this order, the file x.EOE is now 
cleared ready for you to load your next order to this wholesaler. 
Subsequently, the View reply tool lets you view this order (under 
the file name x.BAK). 
This state is critical because a disconnection now will prevent the Series 3 
from reliably determining whether your wholesaler's software will process 
or cancel the order. In practice, the Series 3 assumes on balance of 
probability that the order will get processed but sets up the reply as 
Outcome unknown. Should this assumption be wrong the order will be 
lost, so please do not hesitate to ask your wholesaler's staff to check the 
outcome. The duration of this state is kept as short as conditions allow. 

                                                           

6 Except that if you are using an automatic modem when your installer set up the 
Order program for a manual modem then the program will incorrectly sink into this 
state. Correct with the Access tool and try again. 
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File x.EOE (n lines): Sent OK i checked 
This state confirms that your wholesaler now has a complete record of 
your order x.EOE. Your wholesaler's software is now interrogating the 
master data base on your behalf for stock availability and has reached line 
i inclusive. Any shortages so far reported are shown in the framed 
window (they are also recorded on the Series 3 in file x.BAK for later 
viewing off-line). The speed at which the stock is checked depends mainly 
upon speed of access to the master data base; this can vary or even grind 
to a halt (in which case this state is automatically abandoned). 

File x.EOE (n lines): Sent OK, reply OK 
This state also confirms that your wholesaler now has a complete record 
of your order x.EOE. It confirms that the wholesaler's reply is now 
recorded on the Series 3 in file x.BAK. 

Sending a group of orders 
The Send dialog box File(s) Name field accepts any file specification 
typed over the suggested specification. The .EOE suffix will be assumed if 
you leave it out. To select a group of files you use wildcards within the 
specification; these are the * and ? characters familiar to PC users and 
explained in Psion's Series 3 User Guide Chapter 12 Files and disks. 
For example WELLS* selects all files whose name begins with WELLS (and 
have suffix .EOE). 

When Trying to connect to wholesaler, the Order program 
takes the Access data (wholesaler name and telephone number) from the 
order file current when the Send tool was picked; we will call this the Host 
order file. Each non-empty order file which matches your specification is 
then sent in turn from the Trying to log on state, after which the 
Series 3 disconnects. After you close the Send tool, the original Host order 
file is still the current order. Please note that the Host order is only included 
in the transmission when it too matches your file specification. 

When Trying to logon each individual order, the program compares 
the order's Wholesaler Name with the Host's. If the names are identical 
(up to the shorter of the two should their lengths differ) then the Access 
Code and Password sent are taken from that order file, otherwise they 
are taken from the Host order file. This feature lets you send an order set up 
for another wholesaler to the host wholesaler without needing to alter any 
Access data, and lets you send several orders with different Access data 
to the host wholesaler. 
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Retransmitting an order 
In exceptional circumstances your wholesaler might ask you to repeat a sent 
order, if possible. This is indeed possible anytime before you send the next 
order under the same file name: 

• Pick the View reply tool under the File menu. In the dialog box, 
choose the file which needs to be retransmitted. 

• Pick the Undo send tool under the Edit menu: 

 

Press the letter Y to confirm. This restores the order just as if it had never 
been sent. You may now review and (though this would not be normal 
procedure) even edit or add to the order. Retransmit by picking the Send 
tool under the File menu. 

For clarification, please be aware that under these circumstances the current 
order file is the file x.BAK not x.EOE. Consequently your next order if 
any in x.EOE will not be altered in any way by anything you do in x.BAK. 

If you wish you may revert x.BAK to it's sent state by picking the Undo 
‘‘undo send’’ tool under the Edit menu, so long as you haven't 
altered the order in any way in which case the Edit menu will show 
(can't undo).  
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Viewing wholesalers' replies 
To see your wholesaler's most recent outcome report for the current order 
file, press the button assigned to the Order program (mentioned on page 
3). If you don't know which button this is, or you want to look at the 
outcome report for another order file, pick the View reply tool from the 
File menu: 

 

The above dialog box initially suggests viewing the most recent reply for 
the current order file. Use the arrow keys to rotate the selection through 
other available replies, or press Tab to reveal all files. When you close the 
dialog box (by pressing Enter) you should see a screen like this: 

 

The button assigned to the Order program may now be used to switch back 
to your next order for this file, alternatively pick the Open or the View 
reply tool under the File menu to choose any order file or outcome 
report. 

The framed window's lower pane shows a single order line, including its 
stock availability where the relevant information was received from your 
wholesaler. Where shortages have been reported, the pane is pre-set to show 
the first shortage. You may scroll through the order: 

to the next line with each press of Down Arrow, 
to the previous line with each press of Up Arrow, 
to the next shortage with each Tab or Right Arrow, 
to the previous shortage with each Shift+Tab or Left Arrow. 
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The Order program will display whatever reply data is available. Shortages 
are described as “temporary” unless the wholesaler has given more specific 
information such as “to follow” (on a back order when next in stock), 
“manufacturer cannot supply” or “not on our file”. 

The line immediately above the framed window indicates how much 
information on shortages is available. In the previous figure this line shows 
a message from the wholesaler's software reporting that this order was 
valued and invoiced whilst you were on-line, so we deduce that the shortage 
report is complete. Some other messages you may see on this line are 
explained in the following table: 

Reply cut off after line i 
Due to disconnection, information on shortages is only available up to line 
i inclusive. However, you should assume that your wholesaler's software 
continued to process the order. 

Invalid Access Code  (or similar message) 
This type of message is sent by your wholesaler's software when it could 
not process your order for the reason stated. Please query this with your 
wholesaler's staff, who will usually be able to resolve the matter without 
you retransmitting the order. 

Stock check abandoned 
Your wholesaler's software felt you would be subjected to unreasonable 
delay whilst it attempted to complete checking stock availability. You 
should assume that your order will be processed as soon as possible. In 
this instance the Series 3 may be able to display information on shortages 
up to an unspecified line number. 

Stock not checked 
Your wholesaler's software was not able to check stock availability whilst 
you were on-line. You should assume that your order will be processed as 
soon as possible. In this instance the Series 3 cannot display any 
information on shortages. 

Outcome unknown 
Due to disconnection during the critical Awaiting reply state (see 
page 17) the Series 3 cannot confirm that your wholesaler's software has a 
record of this order. Please query this with your wholesaler's staff, as it 
may be necessary to retransmit the order (though this is unlikely if you 
know you caused the disconnection). 
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Order Files 
The Send tool clears each order file when the Awaiting reply state is 
reached, as mentioned on page 17. When you open such an order file 
afterwards it is empty (as in the figure on page 3) ready for you to load your 
next order. This feature makes it difficult to accidentally duplicate an order. 
It also avoids filling up the Series 3 Internal Disk with old order files 
which would have to be deleted sometime. The View reply tool lets you 
look at the previous order, with its outcome. 

This simple scheme will be entirely adequate for users routinely placing 
orders on a single wholesaler for delivery to a single address. Nevertheless 
the Series 3 provides a comprehensive filing system which is available to 
those whose needs are more elaborate. For a description of this filing 
system (essentially the same as is found on a Personal Computer) please see 
the Psion Series 3 User Guide Chapter 12 Files and disks. 

The Order program identifies the examples shown in this guide by the name 
Order; the Series 3 filing system stores Order on the Internal Disk 
in directory \EOE as up to two files ORDER.EOE and ORDER.BAK. This 
selection was determined by default when you started the Order program 
(see page 3). The identifier for the current order file is always shown in the 
Status Window (see page 3). 

You can make a new order file with the New tool under the File menu: 

 

Overtype the suggested name (which is unsuitable as it is name of the Host 
order, i.e. the one current when the tool was picked) with any name up to 
eight characters long. The .EOE suffix will be assumed if you leave it out. 
If you wish, you may include a pathname specifying another directory 
(which will be created if it does not already exist), otherwise the new file 
will be placed in the same directory as the host. When you close the dialog 
box (by pressing Enter) the new file replaces the host as the current order 
file. The new file is initially empty of lines, however (as the inclusion of the 
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host wholesaler's name in the above dialog box is intended to suggest) it 
will inherit all Access and Format data from the host (see page 24). 

When you have a number of order files on your Series 3 you may use the 
Open tool under the File menu to select the one you wish to work with: 

 

Use the arrow keys to rotate the selection through other available orders 
(within the current directory), or press Tab to reveal all files. When you 
close the dialog box (by pressing Enter) the selected order file replaces the 
host as the current order file. 

For clarification, the Open and View reply tools are identical except 
that Open selects files using the filter *.EOE whilst View reply uses 
the filter *.BAK. In either case the Order program determines whether you 
have selected an un-sent order or a reply from the content of the file, not 
from its name. 

Another way to choose the current order file is from the System button's 
screen (see page 3). This screen lists under the Order icon all files matching 
the specification \EOE\*.EOE on any accessible disk. The current order 
file, if any, is shown in bold text. Use the arrow keys to move the 
highlight onto the order file you wish to make current and press Enter. 
This will start the Order program if it was not already running. If it was 
already running and can switch files it is restored onto the screen after doing 
so; otherwise the request is rejected with a “busy” message. 

Pressing Shift+Enter instead of Enter lets you open another order file 
without closing any already open; Shift+Order button then moves from 
one order file to the next, or Psion+Shift+Order button moves to the 
previous. See Psion's User Guide Chapter 10 Opening more than 
one file. 

Another way to make a new order file is with the New file tool under the 
System button's File menu. In this instance there is no Host order from 
which the new file may inherit Access and Format data. 



24 Order Entry V1.4 for the PSION Series 3 

Access to Wholesaler 
The information the Send tool needs to communicate with a wholesaler is 
held within each order file separately. The Access tool under the Edit 
menu lets you define this information for the current order file: 

 

• All three Phone No fields should dial a number normally 
automatically answered by a modem (please duplicate one of the 
numbers if the wholesaler has less than three such numbers). Enter a 
comma to insert a pause during dialing. A dash rather than a space 
has been used above as punctuation because when the Series 3 
generates DTMF tones it pauses at any space. 

• In the Modem field choose from Hayes (Tone dial), Hayes 
(Pulse dial), Manual or VX-543. Most automatic modems 
claim (or may be configured) to be compatible to Hayes; tone dial is 
quicker than pulse dial but does not work on older exchanges. If the 
modem has non-volatile memory which requires configuration, you can 
use Psion's 3 Link Comms application's Terminal Screen to do 
this. 

• In the Speed(bps) field, choose from V21(300), V22(1200) or 
V22bis(2400). The first is slowest but should always work. Consult 
your modem manual to see if it supports a higher speed. 

Close the dialog box by pressing Enter. If the highlight was in the PIN 
etc... field the program moves on to another dialog box: 
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• In the Wholesaler field, type the wholesaler's name. If multiple 
order files may be sent to this wholesaler in one transmission, the name 
must exactly match (up to the shorter of the two) that of the Host order 
file if the Access Code and Password from this order are not to 
be replaced during transmission by the Access Code and 
Password from the Host order file. 

• The Max lines field cannot exceed 254. The order program stops 
you from exceeding the specified number of lines. The correct value is 
dependent upon the wholesaler's software. 

• Setting the Backorders field to No disables the Order program's To 
follow features when working with this file. 

• Setting the Cases only field to Yes forces all order quantities within 
this file to be flagged as Cases. 

• The Access Code is a number allocated by the wholesaler 
identifying the invoice and delivery addresses for orders sent from this 
file. It is not your Account Number. 

• The Password is a five character sequence allocated by the 
wholesaler. This must be entered (but is never displayed). 

• Press Enter to complete the Access dialog. 

Program installation 
• Press the Series 3 System button. Release as much RAM as possible 

by shutting down all tasks with bold names on the screen which you do 
not need to be active (see page 5). 

• The Order program comprises a single file named EOE.APP. This file 
must be accessible to the operating software of your Series 3; this is 
achieved by placing it on the Internal Disk in directory \APP. 
Copy it there from a SSD (Solid State Disk) using the Copy file 
tool under the File menu, or (through the 3-Link accessory) from a 
Personal Computer running MCLINK using the Remote link tool 
under the Special menu (see Psion's 3-Link manual; please 
remember to turn the Remote link tool OFF afterwards). 
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• If you have kept template order files (i.e. empty orders with pre-set 
Access and Format data) on the SSD or Personal Computer, copy 
these to the Internal Disk directory \EOE. 

• If you have a SSD that will always be fitted on this Series 3 you can 
release nearly 20K bytes of RAM by moving EOE.APP into directory 
\APP on that SSD, then delete EOE.APP from the Internal 
Disk. 

• Pick the Install application tool under the Apps menu: 

 

When the file EOE.APP is on a SSD you will need to change the Disk 
field. The Order program icon should appear at the chosen position when 
you close the dialog box by pressing Enter (you may prefer to change the 
Position field to First or Last). 

• Keeping the highlight under the Order icon, pick the Assign 
button tool under the Apps menu and adjust the dialog box fields 
until they look like this: 

 

Then press Enter to assign the Program button to the Order program. Of 
course you may specify another button if you prefer, or repeat the 
assignment for other buttons. 

• If you wish, you can use the Remove application tool under the 
Apps menu to bar selected built-in applications. This might help to 
avoid RAM being unwittingly consumed by idle button-pressing. 
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• If you did not install template orders, start the Order program either by 
pressing Enter with the highlight on the word Order or by picking 
the New file tool under the File menu. The latter method lets you 
create an order file with a name other than Order. Then pick the 
Access tool under the Edit menu and complete both dialog boxes. 

Problems 
If your Series 3 is not behaving in the way you expect, please see Psion's 
User Guide Chapter 15 Troubleshooting for hints on what to do. If 
you have to reset the Series 3 you will need to repeat the installation 
procedure, but be sure to try soft reset first: if this cures the problem 
all your files will usually be intact. 

Please do not ignore low battery warnings for very long. 
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Access dialog reminder 
Phone No (1)  

Phone No (2)  

Phone No (3)  

Modem Hayes type 
(Tone Dial) 

Hayes type 
(Pulse Dial) 

Manual Datatech 
VX543 

Speed(bps) V21 
(300 bits/sec) 

V22 
(1200 bits/sec) 

V22bis 
(2400 bits/sec) 

 

Wholesaler  

Max lines  

Backorders YES NO 

Cases only YES NO 

Access Code  

Password  
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